Skip to main content

Flashback Player v5.x – “VFW Error, cannot play back the audio stream” workaround

Issue:

The customer reports that they are unable to play videos using version 5 of the Flashback Player, as launching the application produces a “VFW Error, cannot play back the audio stream” fault.

Cause:

It appears that a component of Flashback Player v5 references two incorrect registry entries in Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\ActiveMovie\devenum\{E0F158E1-CB04-11D0-BD4E-00A0C911CE86} causing the application to fail to connect the machine’s audio devices.

Workaround:

A. Reinitializing registry values

  1. On the affected Windows user profile, open Registry Editor. (Win Key + R, then type regedit)

2. Locate and delete the registry entry HKEY_CURRENT_USER\SOFTWARE\Microsoft\ActiveMovie\devenum\{E0F158E1-CB04-11D0-BD4E-00A0C911CE86} You can also use the PowerShell command Remove-Item -Path 'HKCU:\SOFTWARE\Microsoft\ActiveMovie\devenum\{E0F158E1-CB04-11D0-BD4E-00A0C911CE86}' -Force -Verbose

3. Delete the folder C:\Users\*Windows user folder*\AppData\Local\Mobile-Vision (shortcut: Win Key + R, then type %localappdata%)

4. In DES, play a video to relaunch the DES Client and to start the player. This should allow the registry keys to be rebuilt and the player to start correctly.S

B. Overwriting registry values

  1. Locating the registry entries

    a. On the affected Windows user profile, open Registry Editor. (Win Key + R, then type regedit)

    b. Navigate to Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\ActiveMovie\devenum\{E0F158E1-CB04-11D0-BD4E-00A0C911CE86}

  c. Take note of the value of the DSGuid key under DirectSound and the EndpointGuid key under wave.

These values are unique for every machine.

Changing the device IDs

  a. Open the file C:\Windows\setupact.log on the same computer using a text editor.

  b. Use search to locate the old DSGuid and EndpointGuid values you saw in the registry earlier. Note the new value assigned to the device, following the example below.

  c. Edit the key values of DSGuid and EndpointGuid to use the new values shown in the log, and rename the IDs beside the DirectSound and wave items to match. Note that the values may be identical depending on the hardware setup.

   d. Play a video in Flashback Player to confirm if the player launches successfully. Note that this needs to be done in every affected individual user account.